読者です 読者をやめる 読者になる 読者になる

VisualStudioのインストーラー作って .NET Framework のバージョンと一致するようにしてください。と怒られたら

「.NET Framework 起動条件 ‘.NET Framework 4 Client Profile’ のバージョンが、選択した .NET Framework ブートストラップ パッケージと一致しません。.NET Framework 起動条件を更新して、[必須コンポーネント] ダイアログ ボックスで選択した .NET Framework のバージョンと一致するようにしてください。」

全体を.NET4.0 で統一すればおそらくお目にかからないであろうエラー。
少しでもケチって.NET3.5 にしようとか思うと出てくるのではないかと思われるエラー。

.NET系モジュールとインストーラーの.NETのバージョンをあわせないと出る

ネタ元